A Quick Example:

In this section we’ll create an item. I’m going to guide you through the progress step by step. However once you picked up the basics, I strongly recommend that you also read the article “Manual”. You’ll find a lot of useful tricks and all the hotkeys there.

0.       Downloading and extracting
To download the PixelShop 3000 please visit the Fantasy Online forum and open the thread “Download and Getting Started” in the sub forum “PixelShop 3000”. You’ll find the zip download file and some useful information there.
Once you downloaded the zip file you need to extract it into a folder (e.g.: “/ps3k/PS3k.exe”). Now start the program, the auto updater should start downloading. Let it finish, close the program and start it again.
Important: Do not execute the file directly from the zip archive or the auto updater will not work!

If you already read the article “Manual” you can skip the next section.

1.       Organize your windows and drawing board
When you start the PixelShop 3000 you’ll see a lot of windows and it might appear confusing in the beginning. But trust me when I say it’s really simple and you’ll pick it up fast.

You’ll notice a big white sheet in the middle of the program. That is your drawing board. You can move it around with CTRL+ASWD and make it bigger and smaller with CTRL + MOUSEWHEEL. This is very useful to get the most out of you screen resolution and make working convenient. Make sure your drawing board is aligned and is not cut off (a black line should be visible all around it).

The next thing that you should do is detach all windows from the side of the program and drag them into a convenient position. This will make accessing them much faster. If you ever close a window and wonder how to get it back, just go to the menu item “View->Boards” and click on the Window name.

Now your program will look similar to this:

  

1.       About the layers
The PixelShop 3000 is based on layers. So before we can do anything else, we need to create a new layer.

In the window “Layer List” you’ll notice a small “plus” button. Click it and name your new layer “armor”. Create a second layer that you call “background”. The “background” layer should already be selected, but if not, click it (should have a light blue background now).

Now we need to get the background. In the “sprite sheet” window there is a small orange arrow pointing downwards (“Import Style Sheet”). Click it and go to the folder where the program is located. If you did everything according to the first section “Downloading and extracting” you’ll find a file called “body.png” in the subfolder “samples/spritesheets/”. After selecting it you’ll notice a lot of things changed in the program.
First of all there is a giant pixilated character on the drawing board. But also the “Used Color” Window updated and the sprite sheet shows the different animations the character can “perform”. I’ll talk more about all that later.
First let’s get to know the layering business a little better: Select the “armor” layer and import the style sheet “armor-dragonbody.png” from the spritesheets folder. Unfortunately the background is now in front of the armor. Select the “background” layer and click on the green arrow pointing down (“Move Down”) in the “Layer List” window. So we learned: The layers are drawn from the bottom upwards, drawing the topmost layer last (on top).

Next to the each layer you’ll find a small box that is crossed. Hide the “armor” layer by clicking the box with your mouse, then select it and create a new layer called “legs”. This layer should be on the very top now. Make sure it’s selected and jump to the next Section.

2.       Sharpen your pencil
Hopefully you’re looking at something like this now.

Select the animation front view in the “Sprite Sheet” window (the one that is selected in the picture where the character is facing you). Then press the “Play” button in the “Animation” window. You can see the character moving the way it would in the game.

Now it’s time to draw. Select the “Brush” tool from the “Tool Select” Window and select a foreground color from the “Color” window (click on the solid foreground rectangle).
 
Make sure the “legs” layer is selected and carefully redraw the character legs on the drawing board. If you draw a “wrong” pixel use the “Edit->Back” function (or press CTRL+Z). For now we’ll just do it for all three front facing animations. It might also help you to enable the grid in the window “Tool Settings” and the submenu “View”. This is the result I got.

Make sure the legs line up with the armor (just make the armor visible again to check). The result is already pretty ok considering that we just started. But we still need some more contrast. I’d recommend drawing an outline first, but it’s really up to you. This is where you need to be creative!
Also note the “Color Shading” and “Used Colors” windows. They might be really helpful at this point.

3.       The Icon
You might think that it’s really easy to create an icon. And you’re right. But there are some techniques that you should know to make creation fast and efficient.
We’ll reuse the legs that we have already drawn. Select the leg layer and the frame where the character is facing you. Press CTRL+C (this will copy the selected frame) and then press SPACE (this will switch to the icon view).  Now Press CTRL+V (insert) and CTRL+T (increase size), then drag the legs into view again and right click on the drawing board (deselect rectangle). The style of the game requires that all dots for icons are actually two times two pixels big. To change your brush size, change the “Brush Size” in the “Tool Settings” window in the sub window “Brush”.
Now we’re almost finished. Just the background looks awkward. Select the grading tool (F8) and a nice color for the background and foreground. Then click just below the legs into the white area. This affect is really useful to create a nice background. You can experiment with different color. Use CTRL+Z to go back, select a different color and try again.



4.       Let’s talk about Alpha
It is very important that you understand the alpha channel. It is not very difficult, but please read this section carefully nevertheless.
The Alpha Channel is the information (for every pixel and every layer) weather that pixel is visible or not. It is important that you don’t have any dead pixel before you are exporting your creation. Dead pixels are white pixels that should be transparent but are not. They happen when you “erase” pixels by using the color white instead of using the “Alpha” tool.

To check for dead pixel, select the “Alpha” Tool (F5). You’ll notice that a huge amount of pixels just went green. Those pixels are transparent. Make sure there are no visible pixels in places where you didn’t expect them and check that for every layer. If you find one, just use the mouse (left click) on the drawing board to erase it (“make it green”).

5.       Export to Web

For the purpose of this tutorial let’s consider the legs finished (even though I’m pretty sure they’d never make it into the game). Before we can publish our creation we need to check a few things.
Most important is that we select the layer which we want to export. In our case that is the “legs” layer.
The way the animation window shows the character is the same way it will show in the published preview. So we unhide the “Armor” layer.
Also “Legs” is not really a good name, “Double Refined Leather Legs” sounds more catchy. Rename the layer by selecting it then right-click and “rename”. Note that you can still rename your creation once you’ve uploaded it.
Now click “File->Export to Web” and read on. The “Notice Board” Window will tell you if everything did go ok and your standard browser will then open your creation.

If you already read the article “Manual” you might find this section a little boring.

6.       Manage your creations online
The website you’re on now prompts you with a login. Enter your forum/game username and password and login. Read the agreement and confirm if you agree (otherwise you won’t be able to proceed). You will look at a page similar to this one:

This means your creation was successfully linked to your account. Now click on the link “Back to Main Page”.  This will bring you to a list of all your creations uploaded so far. For now it’s just one.

 

I’ll quickly explain all the different columns.

The “Icon” will display a preview of your creation. Depending on the kind of thing you created this might either be the icon or the character animation.

The “Name” column allows you to change the name of your creation. Just click on the pen to edit it.

The “Visible” checkbox is probably the most important field. If you check it your creation will become visible to everyone visiting the ps3k site and users can start rating and liking it.

In the “Set“-field you can give your creation a set name. Stuff that you uploaded will be grouped by set names. This is really helpful when created a whole armor set consisting of different items.

The “Type” just lets you select what kind of item you’ve created.

The “Rating”-stars show the average of all stars users have given your creation and the “Likes” tell you how many users liked your creation. Note that the star rating is only updated every few minutes.

“Icon”, “Layer” and “Animation” let you choose which part of your creation should be visible to the public. So if you’ve created a new trinket you’d hide the “Layer” and “Animation”. If the Icon for your creation is not ready yet, you could hide that as well.

The “remove” button and the “Uploaded” date are pretty much self explaining.

 

So we’re choosing the following settings.

Note that it is not possible to change your icon, layer or animation once you’ve uploaded it. So if you think something needs altering, just upload a new version, hide or delete the old version and unhide the new version. Please don’t leave several version of one creation visible as this gets really confusing.

 

Thank you for reading this Guide and I hope I’ve given you a good overview of what this program can do. Please check the forum if you have any further questions.
flux