Manual

If you don’t want to read through the whole manual and just get “drawing” please read the article “A Quick Example”. However there is very useful information in this section, so you might want to come back later.

When you start the PixelCreator 3000 you’ll see a lot of windows and it might appear confusing in the beginning. But trust me when I say it’s really simple and you’ll pick it up fast.

You’ll notice a big white sheet in the middle of the program. That is your drawing board. You can move it around with CTRL+ASWD and make it bigger and smaller with CTRL + MOUSEWHEEL. This is very useful to get the most out of you screen resolution and make working convenient. Make sure your drawing board is aligned and is not cut off (a black line should be visible all around it).

The next thing that you should do is detach all windows from the side of the program and drag them into a convenient position. This will make accessing them much faster. If you ever close a window and wonder how to get it back, just go to the menu item “View->Boards” and click on the Window name.

Now your program will look similar to this:

Let’s have a look at the different windows. I’ll start with the most important once first.

1.       The Windows

(I)                  The “Color” Window

This window displays your main drawing color (left click) and your alternative drawing color (right click). To select a color, just click on it. A color select window will appear.

If you click “Define Custom Colors”, you can smoothly select colors. The last thing of importance for this window is that when you dbl click on the small lines connecting the foreground with the background color, the colors will swap places.

 

Hotkeys: -

 

(II)                The “Color Shading” Window

This will always show the selected foreground color with different luminescent values. The closest color to the foreground color will have a small rectangle drawn around it. If you want to make your foreground color brighter or darker you can either click the color or use SHIFT+ASDW. This will come in handy if you want to create smooth shading.

 

Hotkeys: SHIFT+ASDW: move to the neighboring color shade

 

(III)             The “Tool Select” Window

This Window lets you select between the different Pen Modes. You can use the hotkeys F1-F8 to select them. You’ll learn more about the modes in the Section “About the Pen Modes”.

 

Hotkeys: F1-F8: Select Paint Mode 1-8.

 

(IV)             The “Navigation” Window

The buttons in this window give you quick access to some basic functions. The first button (“disk”) will (quick) save your project. The second button (“folder”) lets you open a project. The next button (“green arrow on paper”) will export your project to the web (read more about this in the “Export to Web” Section). The fourth and fifth button (“arrows”) will undo/redo the last action you performed. Since you might use that functionality a lot, there are also the hotkeys CTRL+Z and CTRL+Y for it.

Hotkeys:
CTRL+Z: undo last action; CTRL+Y: redo previously undone action

 

(V)               The “Layer List” Window

You will learn more about Layers in the “About the Layers” section. Everything you need to know for now is that your project consists of different Layers. Every Layer includes a style sheet and an icon. The style sheet is used to animate items, characters and monsters in the game. The icon will be the in-game icon for whatever it is that you’re creating (item, skill). Please give you layers meaningful names (they will appear in the web upload, read more about this in the “Export to Web” section).
The buttons let your add a layer (“plus”), rename the selected layer (“edit field”), move the selected layer up/down (“arrows”), make the selected layer visible/hide it (“eye” / “fadeout”), merge all visible layers to the selected layer, delete the selected layer (“red cross”).

 

 

Good to know: (1) A selected layer will be blue if it is visible and red if it’s invisible. You can only alter the icon/style sheet of a visible layer. (2) The first Layer in the list will be drawn on top (if you don’t understand what this means, don’t worry, you’ll understand in the section “About the Layers"). (3) Deleting a layer can’t be undone. (4) You can also click on one of the small rectangles on the right of the Layer List to make the corresponding layer visible/hide it. (5) Layers have unique names.

 

Hotkeys: ALT+SHIFT: only the selected Layer will become visible, if you press it again all Layers will become visible; ALT+WS: move to the next/previous layer in the list; ALT+AD: makes the selected layer invisible/visible

 

(VI)             The “Used Color” Window

This will display the colors that were used in the style sheet and the icon of the current layer. The colors are sorted by hue. Colors will get cut off if there is not enough space in the window to display them. So make sure it’s big enough, when you’re using a lot of different colors.

 

Hotkeys: -

 

(VII)           The “Style Sheet” and the “Icon” window

These windows are very similar to each other.

(1) The “Spirte Sheet” window allows you to work on the different subimages of the sprite sheet. If you click one, it will appear on your drawing board and you can make changes to it. The selected subimage in the sprite sheet is surrounded by a rectangle. If you want to move to a neighbouring subimage, you don’t have to click again, just use ASDW.

(2) When you click on the icon image, it will appear on your drawing board. It has a slightly different ration then the sprite sheet. If you don’t want to move your windows around, just size it down (CTRL+MOUSEWHEEL) untill it fits again.
The sprite sheet and the icon allow you to import pngs (You’ll find a lot of samples in the sample folder). The icon will only allow you to import 32x32 (pixel) pngs and for the spirte sheet you have to use 72x128 (pixel) pngs. To import a png click on the first button (“orange down arrow”). Everything in the layer will be overwritten when doing this. There is also an export function (“orange arrow on sheet”) that will allow you to export the style sheet and the icon of the layer. However this shouldn’t be necessary to use (have a look at the “Export to Web” section). The “white ball”-button will delete everything in the layer (start from scratch).

 

Hotkeys: SPACE: switch between “Icon” and “Style Sheet” window; ASDW: move to neighbouring image in sprite sheet (only when style sheet is selected)

 

(VIII)         The “Animation” window

This window gives you an idea of what your creation will look like ingame. There are four buttons: Start Animating (“play”), Stop Animating (“stop”), Move to next/previous perspective, eg. Sideview, frontview, backview (“downarrow”/“uparrow”).

To change between different backgrounds, just click the image and it will change. I will try to include all major backgrounds in the future to give you an idea how your creation will “blend in” in different areas.

Note that weapons are displayed slightly different in the game then what they look like in the preview. In the game they are drawn behind the character for the “character facing away”-animation and in front for the “character facing us” –animation. PS3k just draws them in the layer they’re in. Have a look at some example sheets to know what I mean.

 

Hotkeys: -

 

(IX)             The “Notice Board”

As the name suggests, this window will keep you updated about all the different things going on in your program. Even if you close it, it will reappear everytime there is a new notification. So make sure you put it into a convenient place.

 

Hotkeys: -

 

(X)               The “Tool Settings” window

 

The window has three subwindows: “Brush”,  “Alpha” and “View”.

The subwindow “Brush” lets you select the brush size. If the option “Use after Color Select” is checked the brush tool is selected after selecting a color with the Color Select Tool. The Option “Use Alpha (Right Click)” will make the right click of the brush tool draw in alpha instead of the background color.

The “Alpha” subwindow lets you select the color that will be used to display the alpha color.

The “View” window lets you enable a grid for your drawing board.

 

Hotkeys: -

 

(XI)             The “Filter” window

The filter window has two effects: “Color Changer” lets you shift the hue value and adjust the lightness and saturation of the current layer. “Edge Correction” makes the egdes of the current layer look more smooth. This is a nice tool if you have a big monetoneous space in you creation and you want to apply some kind of shading. The strength value will determine how strong the edge correction is going to be.

 

Hotkeys: -

 

 

2.       Export to Web
Exporting your creation and showing it to other people was never as easy! It’s just one click away. However you’ll have to consider a few things first:
(1) Name your layers correctly (the layer name will be shown to everyone, so simply calling it “layer” is not a good idea).
(2) Select the layer that you want to export and make sure it’s visible.
(3) The way the animation is shown in the “Animation” window is the way it will be displayed online. So make sure you make the appropriate layers visible in the “Layer List” window.

 

Ok, now we are ready to export. Click the “Export to Web” button in the “Navigation” Window or click the menu item “File->Export to Web”. The “Notice Board” Window will tell you if everything did go ok and your standard browser will then open your creation. It should look similar to this:

This means your creation was successfully linked to your account. Now click on the link “Back to Main Page”.  This will bring you to a list of all your creations uploaded so far.

 

I’ll quickly explain all the different columns.

The “Icon” will display a preview of your creation. Depending on the kind of thing you created this might either be the icon or the character animation.

The “Name” column allows you to change the name of your creation. Just click on the pen to edit it.

The “Visible” checkbox is probably the most important field. If you check it your creation will become visible to everyone visiting the ps3k site and users can start rating and liking it.

In the “Set“-field you can give your creation a set name. Stuff that you uploaded will be grouped by set names. This is really helpful when created a whole armor set consisting of different items.

The “Type” just lets you select what kind of item you’ve created.

The “Rating”-stars show the average of all stars users have given your creation and the “Likes” tell you how many users liked your creation. Note that the star rating is only updated every few minutes.

“Icon”, “Layer” and “Animation” let you choose which part of your creation should be visible to the public. So if you’ve created a new trinket you’d hide the “Layer” and “Animation”. If the Icon for your creation is not ready yet, you could hide that as well.

The “remove” button and the “Uploaded” date are pretty much self explaining.
Note that it is not possible to change your icon, layer or animation once you’ve uploaded it. So if you think something needs altering, just upload a new version, hide or delete the old version and unhide the new version. Please don’t leave several version of one creation visible as this gets really confusing.

 

3.       About the Layers
In Fantasy Online every character that you see walking around, consists of different “Layers” which are drawn on top of each other. Let’s take this one for an example:

(character)

(body)

(hair)

(eyes)

(pans)

(shirt)

 

On the left you can see the character having equipped a whole bunch of different stuff, the other images show the different images which were drawn on top of each other to “create” this character.
So if you wanted to create a new item “trousers”, you could put different layers together and it’d help you drawing them and give you an idea of how they will look like in combination with other stuff. It will also help you to show the item you created “in the best light” when you publish it.
What you don’t really need layers for: Creation of monsters, icon only items, skills and npcs.
There will be a layer merge function later on, for now you’ll have to use copy + paste (see section “About the Pen Modes->Rectangle Tool” and “Other Functionalities->Copy & Paste”) for this.

 

4.       About the Alpha Channel

The Alpha Channel is very important to understand. Since the picture doesn’t “know” which pixel should be transparent, we have to provide this information. This information is stored in the Alpha channel of the png image. You can set the alpha value of a pixel with the Alpha tool (See section “About the Pen Modes” for this). The icon of a layer has a fixed alpha channel, so you won’t be able to modify it.

 

5.        About the Pen Modes
There are seven different pen modes: Brush, Flood Fill, Color Select, Rectangle Select, Alpha brush, Alpha Flood fill, Color Swap.

 

(I)                 Brush
The brush lets you paints on the current layer. Left click will paint with the foreground color, right click with the background color.

 

(II)               Flood Fill

Fills everything that is “attached to the pixel you clicked on and has the same color as that pixel” with the foreground color (left click) or background color (right click) in the current layer.

 

(III)             Color Select
Sets the foreground color (left click) or background color (right click), taking the color from the pixel we clicked on (as displayed).

 

(IV)             Rectangle Tool
This tool lets you select parts of the current layer on the drawing board. A selected part can be moved around. Please read the section “Other functionality->Copy & Paste” for further information.

 



 

(V)               Alpha Brush

When you select this Tool, you’ll notice, that parts of the sheet you’re looking at, will turn green (alpha channel color). Those parts are going to be transparent in the final png-image. Use the left click to make a pixel transparent and right click to remove transparency. Both clicks will also set the pixel color to white. Read Section “About the Alpha Channel” for more Information.

 

(VI)             Alpha Flood Fill

This is very similar to the Flood Fill Tool, except that it “floods” the pixel with “transparency” and white color (left click) or “visibility” and white color (right click). Read Section “About the Alpha Channel” for more Information.

 

(VII)           Color Swap

This tool will change the color of the pixel you clicked on to the foreground color if the pixel color is the background color (left click) or the other way around (right click). This might be useful to alter existing sprite sheets. However there will be more powerful filter for this later on.

 

(VIII)         Gradient Flood Fill

This tool allows you to flood fill with the foreground color fading to the background color. The foreground color will be strongest at the point where you clicked and slowly fade to the background color (left click). Right click will basically do the same (only foreground and background color exchanged). Use undo to try again if you don’t like the result.

 

6.       Other Functionalities

(I)                 Copy & Paste

Copy and Paste are very important functions in most programs. And it’s not different here. You can either access them via the menu item “Edit” or through the hotkeys (see “hotkeys” below).
If you use copy while a rectangle is selected the rectangle will be copied to clipboard (see section “About the Pen Modes-> Rectangle Tool”). If no rectangle was selected, the whole drawing board will be copied (layer).
To paste the selection there are two different ways, one will insert the clipboard transparent, the other one will insert it without transparency (to the current layer). The difference is that the second option will overwrite pixels in the current layer, while the first one will keep them (if they’re transparent).  (Ok, hard to explain, but just try it, it’s really easy to understand).

Cut will simply copy the selection and then erase it (or copy and erase the whole drawing board if nothing was selected).

Hotkeys: CTRL+C copy; CTRL+V insert; CTRL+E insert transparent; CTRL+X cut; DEL erase

 

(II)               Edit Image function

You can manipulate the image using rotate, flip or zoom(x2) functions (Menu item “Image”). These functions will rotate/flip/zoom the selection or if nothing was selected the whole drawing board. The flip option is very useful if you have one side-view of the sprite sheet done and want to create the other side-view. The zoom option is really nice if you want to create an icon for an item that you’ve already created (read the article “A Quick Example” for more info)

 

Hotkeys: CTRL+F: Flip Horizontal; CTRL+R: Rotate 90 deg; CTRL+T: Zoom (x2)

 

(III)             Auto Updater

The auto updater will keep your PixelShop 3k up to date and download available samples and content. If you want to disable it however you’ll find the option “Update on Start” and “Update every 10 minutes” in the menu “Tools->Settings”. Once they’re unchecked the updater will only update on demand (menu “Help->Check for Update”). The “Notice Board” Window will keep you informed about the auto updater activity.

 

Thank you for reading this Guide and I hope I’ve given you a good overview of what this program can do. Please check the forum if you have any further questions.
flux